Multidesk.be » Forums » Software Algemeen » Opera

  • Pagina
  • 1 van 1
0 gasten lezen dit onderwerp.
^ Onderwerp geschreven door Corona op vrijdag 8 april 2016 om 13:07:25.
Corona's avatar
Multiviteit: 1388
Met dank aan onze overheid worden wij binnen zeer afzienbare tijd gedwongen om gebruik te maken van het ehealthplatform. Berichten zullen, onder professionele zorgverleners, dan verplicht geŽncrypteerd worden verzonden (daar kan ik nog inkomen).

Probleem: om de geŽncrypteerde versie van de ehealth-mailbox te gebruiken, wordt gebruik gemaakt van java.
- Chrome ondersteunt java niet meer, dus onbruikbaar
- Firefox zou het nog moeten doen, maar blijft hangen (certificaat in de keystore is niet bereikbaar); dus ook niet bruikbaar
- IE11 werkt perfect (maar gebruik ik eigenlijk liever niet)
- gisteren heb ik Opera eens uitgeprobeerd; daar zou een eigen java-applet inzitten, maar dat schijnt ook niet te werken, want die gaat zelfs niet op zoek naar de keystore

De hamvraag: kent er iemand een truuk om firefox of opera wel aan de praat te krijgen?

BTW: ik draai W7 professional (en kan niet upgraden naar hoger, omdat dan mijn RX-software niet meer ondersteund wordt; W7 32 bit is het maximum dat de rx-hardware! aankan)
^ Reactie #1 geschreven door thekid op zaterdag 9 april 2016 om 11:22:03.
thekid's avatar
Multiviteit: 5273
Moderator
Hey Corona,

Ik heb het ook net getest en enkel in internet explorer lukt het mij java te laten werken, ook herinstallatie jre, sdk, en settings in java control panel nagekeken.

Ik denk dat je in dit geval geen keuze zal hebben en IE11 zal moeten gebruiken.

Ik test het nu nog even verder...

Opera heb ik ook vers geÔnstalleerd maar die doet het ook niet, en hun opvolger Vivaldi is op Chrome gebasseerd zo die zal het ook niet meer doen :(

*update*

Het werkt bij mij in FireFox Developer Edition, heb er wel de JRE opnieuw moeten downloaden (had geen java geÔnstalleerd staan). Allesinds zal je dit slechts 1 jaartje nog verder helpen, daar eind dit jaar (2016) de support verloopt voor NPAPI.
https://www.mozilla.org/en-US/firefox/developer/

Je kan de overheid aanmanen naar javawebstart om te schakelen :)
Deze tekst werd het laatst bewerkt voor 29.13 % door thekid op zaterdag 9 april 2016 om 11:29:35.
"Human beings make life so interesting. Do you know, that in a universe so full of wonders, they have managed to invent boredom." - Death in Hogfather
^ Reactie #2 geschreven door Corona op zaterdag 9 april 2016 om 12:49:41.
Corona's avatar
Multiviteit: 1388
Ik krijg het niet aan de praat.
Ik moet mij identificeren met mijn EID, en die applet is ook uitgeschakeld.
Ik heb geprobeerd om via about:config dat te overriden, maar dat lukt ook niet.

Wat wel lukt: je kan een omleiding in firefox instellen, zodat hij naar IE gaat, en dan lukt het wel.
Maar dat werkt ook in de gewone firefox. Ik heb wel de indruk dat de develpers versie veel sneller opstart.

Overigens had ik al een beleefde brulmail naar de helpdesk van eheath gestuurd om ze op dat java-probleem te wijzen. Maar dat is evenzeer geldig voor ons aller EID.

De mailbox die we bij ehealth ter beschikking hebben is trouwens een luizige 10MB groot; daar gaan we vet mee zijn.

Onze overheid is, zoals gewoonlijk, weer bezig op een niveau van 10 jaar geleden.
Deze tekst werd het laatst bewerkt voor 31.31 % door Corona op zaterdag 9 april 2016 om 13:44:23.
^ Reactie #3 geschreven door thekid op maandag 11 april 2016 om 16:55:03.
thekid's avatar
Multiviteit: 5273
Moderator
Mja, dan zit je met IE opgezadelt :) Ik kan mij niet inbeelden dat de overheid geen meldpunt heeft voor zulke zaken ;)

*edit*
bvb: https://www.ehealth.fgov.be/nl/neem-contact-op-met-de-openbare-instelling-eHealth-platform

Wie weet kunnen die je dan aanraden wat je net wel moet/kunt gebruiken
Deze tekst werd het laatst bewerkt voor 43.41 % door thekid op maandag 11 april 2016 om 16:57:32.
"Human beings make life so interesting. Do you know, that in a universe so full of wonders, they have managed to invent boredom." - Death in Hogfather
^ Reactie #4 geschreven door Corona op maandag 11 april 2016 om 18:48:24.
Corona's avatar
Multiviteit: 1388
"Overigens had ik al een beleefde brulmail naar de helpdesk van e-health gestuurd om ze op dat java-probleem te wijzen. "


Dat had ik al gestuurd via de link die ook jij aangaf. Tot op heden noegabollen reactie.
Ze zullen het waarschijnlijk te druk hebben met reclameren omdat ze voortaan even lang gaan moeten werken als een niet ambtenaar. (party)
Deze tekst werd het laatst bewerkt voor 0.14 % door Corona op maandag 11 april 2016 om 19:38:59.
^ Reactie #5 geschreven door Corona op maandag 11 april 2016 om 19:25:32.
Corona's avatar
Multiviteit: 1388
update:

Het probleem met mijn EID heb ik via de extensions kunnen oplossen: standaard is die uitgeschakeld, maar je kan die via' menu - add-ons - extensions' activeren.

Vervolgens kan je doorgaan, en komt er op zeker ogenblik juist onder de bookmarks-toolbar een balk tevoorschijn met een de vraag of je java wil inschakelen. Ja dus, en antwoord onthouden.

En hip hoi hoera, ik kan de keystore benaderen en een geŽncrypteerd bericht ontcijferen.

Dit geldt dus voor Firefox developer edition. (in de gewone firefox gaat firefox "hangen", daar werk het dus niet).

Probleem opgelost, met dank aan thekid _O_(thumbsup) (en aan mijn eigen koppige zelf, die toch niet te rap de handdoek in de ring gooit :P )
En hopelijk blijft het toch nog langer dan een jaartje werken, of gaat onze overheid toch in actie schieten om het probleem dat zich gaat stellen op te lossen, en liefst iets rapper dan gewoonlijk; dat wil dus zeggen VOOR het probleem zich stelt.(wall)
Deze tekst werd het laatst bewerkt voor 15.43 % door Corona op maandag 11 april 2016 om 19:31:59.
^ Reactie #6 geschreven door Corona op dinsdag 12 april 2016 om 19:33:52.
Corona's avatar
Multiviteit: 1388
Even een paar antwoorden van de helpdesk van e-health.
En even voor de volledigheid: na op firfox developer edition zowel het uitlezen van de EID als het uitvoeren van java aan de praat gekregen te hebben, is deze in opstart ook ellendig traag geworden, nog trager dan de gewone firefox.
Hun antwoord dat java in 32 bit in de gewone versie van firefox wel nog werkt is trouwens niet correct.

We zijn ons er van bewust dat Java in de browser een doodlopend spoor is. De meeste browsers hebben support voor de Java plugin al verwijderd, Java zelf zal vanaf versie 9 de plugin beginnen uitfaseren.

Voorlopig echter bieden Firefox en Internet Explorer nog steeds de mogelijkheid om de eHealthBox web app te gebruiken. Voor de toekomst echter zoeken we zelf nog steeds naar oplossingen. De moeilijkheid ligt in het gebruik van end-to-end encryptie. Cryptografie moet dus client side geimplementeerd worden. eHealthBox is bij ons echter lang niet de enige toepassing met een Java Plugin, er wordt dus op een hoger niveau gezocht naar een algemene oplossing


In Firefox 32 bit werkt Java tot op heden wel nog. Het is in de 64 bits versie van enkele maanden geleden dat support voor Java verwijderd werd. Wij zullen onze aanbevelingen wijzigen zodat er specifiek naar Firefox 32 bit verwezen wordt.

Eind dit jaar echter zal Firefox inderdaad ondersteuning voor Java volledig laten vallen. Vanaf dan is Internet Explorer de enige browser die de plugin nog zal ondersteunen.

Mijn conclusie: welke idioot start er voor een bepaalde beroepsgroep een systeem op, verplicht te gebruiken, dat binnen het jaar onbruikbaar zal zijn en waarvoor ze geen oplossing klaarhebben.
Hemeltergend toch?
Deze tekst werd het laatst bewerkt voor 13.07 % door Corona op dinsdag 12 april 2016 om 19:37:30.
^ Reactie #7 geschreven door Cdude op dinsdag 12 april 2016 om 19:49:14.
Cdude's avatar
Multiviteit: 5427
Eat my shorts :)

Dixit

welke idioot start er voor een bepaalde beroepsgroep een systeem op.....

De (tromgeroffel) overheid en hun contractors omdat die hoe dan ook betaald worden (evil)
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe."
"Friendship is like peeing in your pants : everybody can see it but only u can feel it's warmth"
^ Reactie #8 geschreven door RedRooster op woensdag 13 april 2016 om 14:05:56.
RedRooster heeft nog geen avatar toegevoegd
Multiviteit: 281
Bijna dood
Wat is het probleem?
Installeer de laatste versie van Java.
Dan de BeID applicatie en test dan de smartcard.

In Firefox/waterfox, ga naar de add-ons Manager en zoek daar naar Belgium-eID.
Installeer de add-on, herstart de browser.
Lukt dat niet, installeer de laatste versie van firefox/waterfox.

En voila. Nu nog hopen dat je het pin nummer van uw identiteitskaart nog kan herinneren.

Ook nuttig voor het invullen van uw jaarlijks opstel naar de fiscus in plaats van token te werken.

Want als er een Trojaans paard op uw computer staan, vroeg of laat zijn alle tokens de revu gepasseerd
en dan neemt de snoodaard even de computer over en krijgt zo wat meer inzicht op uw identiteit of begint te sjamfoeteren met de gegevens.
Deze tekst werd het laatst bewerkt voor 38.29 % door RedRooster op woensdag 13 april 2016 om 14:13:05.
  • Pagina
  • 1 van 1

Snel-antwoordformulier
Toon uitgebreid antwoordformulier Bericht nalezen Bericht plaatsen