Multidesk.be » Forums » Unix/Linux » Disable alle shortcuts voor kiosk modus in ubuntu

  • Pagina
  • 1 van 1
0 gasten lezen dit onderwerp.
^ Onderwerp geschreven door BoeMan op donderdag 21 augustus 2014 om 14:48:23.
BoeMan heeft nog geen avatar toegevoegd
Multiviteit: 154
Hallo,

ik ben voor school een deb package aan het maken dat na installatie het mogelijk maakt om in te loggen op een nieuw gebruikeraccount. Direct na het inloggen wordt er de chromium browser gestart naar een bij de installatie gekozen website. Ook zouden alle shortkeys zoals ALT+F4 natuurlijk verwijderd moeten worden, zodat de browser alleen gesloten kan worden met een vooraf bij de installatie gekozen shortcut.

Nu lukt het wel om de browser te openen bij login, en ook alle shortcuts worden gedisabled, dat laat dconf-editor me toch geloven. Want ik kan nog steeds de browser sluiten met ALT+F4

Dit is een afbeelding van mijn dconf-editor nadat de browser gesloten is
Bijlage:
d1db3505a4ba01416f7f708d0ad7ec37.jpg

Zoals u ziet zijn daar alle binds leeg, alleen is de close bind niet vervangen door mijn bind die ik zo heb doorlopen in mijn startup script.
gsettings set org.gnome.desktop.wm.keybindings close ['<ALT>b']

Alle andere binds worden leeggemaakt op deze manier:
gsettings set org.gnome.desktop.wm.keybindings begin-resize []


Ik zit al 3 dagen vast met dit probleem en begint heel vervelend te worden, zeker omdat de andere 95% van het project feilloos werken, maar een kiosk die met alle shortcuts gesloten kan worden is natuurlijk geen kiosk.

Hopelijk kan iemand van jullie me helpen.

Mvg
Gijs
^ Reactie #1 geschreven door thekid op vrijdag 22 augustus 2014 om 12:38:42.
thekid's avatar
Multiviteit: 5273
Moderator
Het sluiten is eerder een optie van de window manager, dan van google chrome.

Daarmee is het natuurlijk moeilijk om dit via settings in chrome te veranderen. Uiteindelijk moet je toch ook de Kiosk app kunnen afsluiten.

Een paar opties die ik zie:
- In de kiosk app inbouwen dat die niet gesloten kan worden (dan kan je via een pwd protected link ervoor zorgen dat je toch de browser kan afsluiten)
- In chrome instellen, dat bij het afsluiten, het systeem de actieve gebruiker opnieuw uitgelogt word (eigenlijk het "veiligste")
"Human beings make life so interesting. Do you know, that in a universe so full of wonders, they have managed to invent boredom." - Death in Hogfather
^ Reactie #2 geschreven door BoeMan op vrijdag 22 augustus 2014 om 17:46:20.
BoeMan heeft nog geen avatar toegevoegd
Multiviteit: 154
Thekid,

De dconf editor slaat op alle shortcuts, niet enkel die van chrome, en ik ben er nu in geslaagd mijn shortcutnaar de dconf editor te krijgen, maar de werking blijft hetzelfde. Dus nog steeds ALT F4 mogelijk en mijn shortcut niet.

Zoals jij zegt, lijkt me het ook de beste optie mijn shortcut te koppelen aan het uitloggen van het systeem. Maar dan moeten nog steeds alle andere shortcuts gedisabled worden en dat lukt me nog steeds niet :)
Als me dat lukt is het gewoon een kwestie van mijn shortcut te koppelen aan logout ipv close.

Mvg
^ Reactie #3 geschreven door thekid op vrijdag 22 augustus 2014 om 22:31:22.
thekid's avatar
Multiviteit: 5273
Moderator
deze vraag ziet er eigenlijk heel gelijk uit

http://askubuntu.com/questions/433294/run-bash-profile-script-at-login

werkte deze niet?
"Human beings make life so interesting. Do you know, that in a universe so full of wonders, they have managed to invent boredom." - Death in Hogfather
^ Reactie #4 geschreven door BoeMan op zaterdag 23 augustus 2014 om 10:38:35.
BoeMan heeft nog geen avatar toegevoegd
Multiviteit: 154
Thekid,

haha dat is mijn vraag op askubuntu.com ;)
Mijn vraag daar was hoe ik het kan laten runnen bij het inloggen, ik zette mijn code daar in .bash_profile, maar dit script wordt niet gebruikt als .profile bestaat, en dat bestaat standaard :) Daarom zet ik nu alles naar .profile.

Maar ondertussen is mijn script wat aangepast.
Dit is mijn script dat een disable bestand maakt, dat gerunt wordt bij het aanloggen van het nieuwe account.

CODE
  1. #!/bin/bash
  2. user=$(cat kiosk/kiosk-0.1-1/.username)
  3. keys=$(cat kiosk/kiosk-0.1-1/keys)
  4. basis='<Control><Alt>'
  5. teken="'"
  6.  
  7. website=`zenity --entry --title="Website" --text="Voer de kiosk website in"`
  8. while [ -z $website ]
  9. do
  10.         website=`zenity --entry --title="Website verplicht" --text="U moet een website invullen"`
  11. done
  12.  
  13. shortkey=`zenity --entry --title="Shortkey" --text="Uw shortkey is een combinatie van <Control> + <Alt> + een letter\n\n Specificeer uw letter"`
  14. while [ $shortkey = *[^A-Z]* ] || [ -z $shortkey ];
  15.         do
  16.                 shortkey=`zenity --entry --title="Shortkey verplicht" --text="Uw shortkey is een combinatie van <Alt> + een letter"`
  17. done
  18.         result=$teken$basis$shortkey$teken
  19.         zenity --info --title="Uw kiosk parameters" --text="Website: $website \nShortkey: $result \n\nLog nu aan met het nieuwe account!"
  20.  
  21. echo $result >> kiosk/kiosk-0.1-1/.mijnshortkey
  22.  
  23. echo "#!/bin/bash" >> disable
  24. echo "$keys" >> disable
  25. echo  "gsettings set org.gnome.desktop.wm.keybindings close \"[$result]\"" >> disable
  26. echo "/usr/bin/chromium-browser $website --kiosk --no-defualt-browser-check --disable-translate" >> disable
  27. chmod +x disable
  28. chown $user:$user /home/$user/disable
  29. mv disable /home/$user
  30.  
  31. echo "bash disable" >> /home/$user/.profile
  32.  


Ik disable alle keys met deze lijnen code
CODE
  1. gsettings set org.gnome.desktop.wm.keybindings activate-window-menu []
  2. gsettings set org.gnome.desktop.wm.keybindings begin-move []
  3. gsettings set org.gnome.desktop.wm.keybindings begin-resize []
  4. gsettings set org.gnome.desktop.wm.keybindings close []
  5. gsettings set org.gnome.desktop.wm.keybindings cycle-group []
  6. gsettings set org.gnome.desktop.wm.keybindings cycle-group-backward []
  7. gsettings set org.gnome.desktop.wm.keybindings cycle-panels []
  8. gsettings set org.gnome.desktop.wm.keybindings cycle-panels-backward []
  9.  

Enzovoort, het zijn er veel.

Onderaan het disable script staan deze lijnen
CODE
  1. /usr/bin/chromium-browser $website --kiosk --no-defualt-browser-check --disable-translate
  2. gsettings set org.gnome.desktop.wm.keybindings close ['<Control><Alt>b']


En in dconf editor zijn alle shortkeys gedisabled en mijn Control + Alt + b staat in de close bind. Maar werkt niet

Mvg
  • Pagina
  • 1 van 1

Snel-antwoordformulier
Toon uitgebreid antwoordformulier Bericht nalezen Bericht plaatsen