Multidesk.be » Forums » Netwerken » FTP-verbinding ZyXEL NSA320 NAS lukt niet

  • Pagina
  • 1 van 1
0 gasten lezen dit onderwerp.
^ Onderwerp geschreven door Ezio op donderdag 26 december 2013 om 15:25:47.
Ezio's avatar
Multiviteit: 973
Y'ello,

Ik heb mijn NAS het statische IP adres 192.168.0.200 gegeven.
Wanneer ik binnen mijn netwerk via Filezilla een verbinding maak lukt dit zonder problemen.
Helaas lukt het niet om buiten mijn netwerk mijn NAS via FTP te benaderen.

Dit is wat ik gedaan heb:
  • In de instellingen van de NAS staat er dat de FTP-verbinding via poort 21 loopt, dit heb ik gewijzigd naar poort 1515 (omdat Telenet het niet toestaat om poorten onder de 1024 te portforwarden)
  • Vervolgens heb ik in mijn.telenet.be 'geportforward'


  • http://img163.imageshack.us/img163/4784/wn5k.jpg

  • Via CanYouSeeMe.org test ik of de poort nu effectief open staat. Check.

  • Via No-IP heb ik ervoor gezorgd dat mijn publiek IP adres correspondeert met een domeinnaam.

  • Via FTPTest.net test ik of mijn NAS bereikbaar is van buiten het netwerk. Ik krijg echter volgende error:

    http://img191.imageshack.us/img191/6622/lz2p.jpg



Hier nog even een screenshot van de FTP configuratie van de NAS :)

http://img713.imageshack.us/img713/6580/yw7t.jpg


FTP is trouwens geen veilig protocol, kan ik Secure FTP gebruiken of is dit niet mogelijk?
Moest het niet mogelijk zijn zou ik dan uiteraard wel het 'normale' FTP-protocol gebruiken. Maar wat kunnen die badass nerds met slechte bedoelingen dan precies zien, enkel de mappen die met iedereen gedeeld zijn, toch? De andere mappen in mijn NAS zijn immers gebruikersmappen en die zijn beveiligd met een gebruikersnaam en wachtwoord. Met andere woorden, om het mapje Jan te bekijken moet je de gebruikersnaam en wachtwoord van Jan ingeven.

Thx!

Greetz,
Thibault
I'm a gamer because I don't have a life... I've chosen to have many
^ Reactie #1 geschreven door thekid op donderdag 26 december 2013 om 16:11:06.
thekid's avatar
Multiviteit: 5273
Moderator
je kan al eens kijken naar "Customize the port range for data transfer"

Je moet er rekening mee houden dat alle transfers via FTP meestal gebruik maken van de passieve verbinding (-> een nieuwe verbinding over een andere poort)

Deze passieve verbinding moet dan ook een poort zijn die openstaat op je netwerk.

Je kan een paar extra dingen proberen, je kan bvb een ftp client gebruiken die geen gebruik maakt van de passieve mode (nadelen: geen multitransfers, en zolang je download actief is kan je ook niks anders doen op je server)

Verder denk ik dat het IP adres dat je NAS doorgeeft, niet echt correct is :) Voor het interne netwerk klopt het natuurlijk wel, je nas heeft vermoedelijk ip: 192.168.0.200 (poort 121-198). Daar zou je beter eens in de manual van je nas kijken hoe je het adres kunt vertalen naar je externe adres ;)
"Human beings make life so interesting. Do you know, that in a universe so full of wonders, they have managed to invent boredom." - Death in Hogfather
^ Reactie #2 geschreven door Ezio op donderdag 26 december 2013 om 23:15:14.
Ezio's avatar
Multiviteit: 973

Dixit

Dixit thekid op 26/12/2013 16:11:06:

je kan al eens kijken naar "Customize the port range for data transfer"

Welke begin- en eindpoort zou ik dan moeten opgeven bij écustomize the port range for data transfer"?
Momenteel heb ik deze op 1520-1530 staan. De "connection limit" staat dan wel op 5.

Dixit


Je moet er rekening mee houden dat alle transfers via FTP meestal gebruik maken van de passieve verbinding (-> een nieuwe verbinding over een andere poort)

Deze passieve verbinding moet dan ook een poort zijn die openstaat op je netwerk.

En welke poort moet ik dan precies openzetten? Ik heb ergens gelezen dat de standaardpoorten die je moet openzetten voor passieve FTP 55536-55539 zijn. Dit heb ik dan ook gedaan maar helaas lukt het nog steeds niet :(

Dixit

Verder denk ik dat het IP adres dat je NAS doorgeeft, niet echt correct is :) Voor het interne netwerk klopt het natuurlijk wel, je nas heeft vermoedelijk ip: 192.168.0.200 (poort 121-198). Daar zou je beter eens in de manual van je nas kijken hoe je het adres kunt vertalen naar je externe adres ;)

Het vaste IP adres van mijn NAS is inderdaad 192.168.0.200. Om verbinding te maken met mijn NAS heb ik toch enkel het publiek IP adres (WhatIsMyIP.org )en mijn poort (1515) nodig?
Deze tekst werd het laatst bewerkt voor 0.04 % door Ezio op donderdag 26 december 2013 om 23:18:02.
I'm a gamer because I don't have a life... I've chosen to have many
^ Reactie #3 geschreven door thekid op vrijdag 27 december 2013 om 10:10:55.
thekid's avatar
Multiviteit: 5273
Moderator
Het is inderdaad enkel het vaste IP adres dat je nodig hebt, echter, het IP dat teruggestuurd wordt in uw passieve aanvraag, toont ook aan dat je NAS het verkeerde IP doorgeeft :)

Je kan het eventueel eens proberen met LeechFTP. Daar kan je ook kiezen om de passieve verbinding niet te gebruiken, dan zou je op zijn minst moeten kunnen browsen op je server :)
"Human beings make life so interesting. Do you know, that in a universe so full of wonders, they have managed to invent boredom." - Death in Hogfather
^ Reactie #4 geschreven door Ezio op vrijdag 27 december 2013 om 10:25:28.
Ezio's avatar
Multiviteit: 973
Passive Mode stond reeds uitgeschakeld op LeechFTP en toen werkte het niet. Maar wanneer ik mijn "firewall settings" op PASV Mode zette kreeg ik al een ander resultaat:

http://img585.imageshack.us/img585/4485/9gbl.jpg

Helaas krijg ik mijn bestanden toch niet te zien.
Deze tekst werd het laatst bewerkt voor 3.26 % door Ezio op vrijdag 27 december 2013 om 10:25:49.
I'm a gamer because I don't have a life... I've chosen to have many
  • Pagina
  • 1 van 1

Snel-antwoordformulier
Toon uitgebreid antwoordformulier Bericht nalezen Bericht plaatsen