Multidesk.be » Forums » Programmeren algemeen » Step into

  • Pagina
  • 1 van 1
0 gasten lezen dit onderwerp.
^ Onderwerp geschreven door NightCreature op vrijdag 19 oktober 2007 om 00:20:11.
NightCreature's avatar
Multiviteit: 1196
MSc.
Ik weet niet zeker waar ik dit moet zetten maar het is niet echt een C/C++ probleem vandaar dat ik het hier plaats.

Het probleem dat ik heb is dat ik niet meer in staat ben om door mijn code heen te steppen als ik aan het debuggen ben.
De IDE die ik gebruik is VS2005(Team Foundation) en VS2005Express (Omdat mijn laptop geen plaats heeft voor VS2005).
Enkel het project SpaceSim compilet naar een exe al de rest van mijn projecten compilen naar .lib files(zie screen shot).

Weet iemand hoe ik dit kan oplossen zodat ik weer kan debuggen. Want als ik nu een breakpoint op een functie zet uit een lib kan ik die functie niet in steppen. Dit maakt debuggen nogal lastig omdat ik dan naar assembler moet gaan kijken. Dit is niet de beste optie hiervoor.

Aanvulling


Screenshot vergeten

Bijlage: 6711ef3aaabcf2ee7f39872b4c81f587.jpg
[\edit]
I need thought completion.
Shaders, een beetje vreemd maar wel lekker (voor de ogen dan he)
2.83Ghz Q9550 HD4850 512MiB 4GiB 1333Mhz DDR3 RAM
http://paulintheuk.blogspot.com
FE Programmer @ Codemasters (Front End)
^ Reactie #1 geschreven door Suriv op vrijdag 19 oktober 2007 om 18:24:50.
Suriv's avatar
Multiviteit: 7607
Moderator
Kijk eens hier: (VS2005)
Project Properties > tabblad Compile > Advanced compile options > kijk daar eens, zorg ervoor dat Generate Debug Info niet op "None" staat.

Aanvulling



Staat je VS hosting process aan (<naam project>.vshost.exe)?

Deze tekst werd het laatst bewerkt voor 19.83 % door Suriv op vrijdag 19 oktober 2007 om 18:25:34.
^ Reactie #2 geschreven door NightCreature op maandag 22 oktober 2007 om 20:43:56.
NightCreature's avatar
Multiviteit: 1196
MSc.
http://forums.microsoft.com/msdn/ShowPost.aspx?postid=2290300&SiteID=1
Dit is het antwoord let op wel in het engels

Suriv ik heb het hier over een native c++ project, ik heb geen tabbladen in mijn project opties enkel een tree. En daar staat geen compile in
Deze tekst werd het laatst bewerkt voor 37.66 % door NightCreature op maandag 22 oktober 2007 om 20:45:27.
I need thought completion.
Shaders, een beetje vreemd maar wel lekker (voor de ogen dan he)
2.83Ghz Q9550 HD4850 512MiB 4GiB 1333Mhz DDR3 RAM
http://paulintheuk.blogspot.com
FE Programmer @ Codemasters (Front End)
  • Pagina
  • 1 van 1

Snel-antwoordformulier
Toon uitgebreid antwoordformulier Bericht nalezen Bericht plaatsen